digitalSTROM Systems Status

Incident

Problems with SHOP

Closed | Feb 04, 2019 | 18:08 GMT+01:00

The service has been resumed and now our SHOP is back online

Resolved | Feb 04, 2019 | 17:08 GMT+01:00

The service has been resumed and now our SHOP is back online

Investigating | Feb 04, 2019 | 16:47 GMT+01:00

We have detected problems in our SHOP website. We have escalated the issue to the responsible team.

A possible root cause has been identified and the engineers working to resolve the issue.

Status Page powered by Admin Labs